Konfigurasi multi-area OSPF di Router Cisco

Konfigurasi OSPF di Router-JKT:
(config)# interface loopback 0
(config-if)# ip address 10.0.255.1 255.255.255.255      ==> sebagai router-id OSPF
(config-if)# no shutdown

(config-if)# router ospf 1                                                ==> menggunakan process-id 1
(config-router)# network 10.0.255.1 0.0.0.0 area 0
(config-router)# network 10.0.0.0   0.0.0.3 area 0
(config-router)# network 10.0.0.4   0.0.0.3 area 0
(config-router)# end

Konfigurasi OSPF di Router-SBY:
(config)# interface loopback 0
(config-if)# ip address 10.0.255.3 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 1
(config-router)# network 10.0.255.3 0.0.0.0 area 0
(config-router)# network 10.0.0.4   0.0.0.3 area 0
(config-router)# network 10.2.1.0   0.0.0.3 area 2
(config-router)# end

Konfigurasi OSPF di Router-MKS:
(config)# interface loopback 0
(config-if)# ip address 10.2.255.1 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 2
(config-router)# network 10.2.255.1 0.0.0.0 area 2
(config-router)# network 10.2.0.0   0.0.0.255 area 2
(config-router)# network 10.2.1.0   0.0.0.3 area 2
(config-router)# end

Konfigurasi OSPF di Router-MDN:
(config)# interface loopback 0
(config-if)# ip address 10.0.255.2 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 2
(config-router)# network 10.0.255.2 0.0.0.0 area 0
(config-router)# network 10.0.0.0   0.0.0.3 area 0
(config-router)# network 10.1.1.0   0.0.0.3 area 1
(config-router)# end

Konfigurasi OSPF di Router-ACEH:
(config)# interface loopback 0
(config-if)# ip address 10.1.255.1 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 3
(config-router)# network 10.1.255.1 0.0.0.0 area 1
(config-router)# network 10.1.0.0   0.0.0.255 area 1
(config-router)# network 10.1.1.0   0.0.0.3 area 1
(config-router)# end

Untuk verifikasi konfigurasi OSPF:
# sh ip route          ==> melihat routing table
# sh ip protocol       ==> melihat routing protocol yg telah dikonfigurasi
# sh ip ospf neighbor  ==> melihat neighbor table OSPF
# sh ip ospf database  ==> melihat LSDB OSPF
# sh ip route ospf     ==> melihat routing table OSPF

# debug ip ospf packet ==> melihat proses mengirim & menerima paket OSPF
# debug ip ospf event  ==> melihat event yg terjadi di OSPF
# terminal monitor     ==> utk melihat hasil debug (khusus bagi yg via telnet/SSH)
# no debug all  ATAU  #undebug all   ==> mematikan proses debugging

Catatan : utk menghitung wildcard mask, cara paling mudah adalah dengan cara: 255.255.255.255-subnet mask

contoh:
10.0.255.1 255.255.255.255 ; wildcard mask = 255.255.255.255-255.255.255.255 = 0.0.0.0

10.0.0.0 255.255.255.252 ; wildcard mask = 255.255.255.255-255.255.255.252 = 0.0.0.3
10.0.0.4 255.255.255.252 ; wildcard mask = 255.255.255.255-255.255.255.252 = 0.0.0.3

Ethernet interface adalah physical interface
Loopback interface adalah logical interface. Pada OSPF, loopback interface digunakan sebagai OSPF router-id. Agar semua interface router kita (physical maupun logical interface) bisa di-ping atau di-telnet, maka semua interface (physical: ethernet, serial, dll. logical: loopback, dll) di-advertise ke router lain, menggunakan command ‘network’ di bawah command ‘router ospf’.semoga bisa membantu, gan :)

sumber : http://aditya.hananto.net/2010/01/06/konfigurari-ospf-multi-area-di-router-cisco/

This entry was posted in Jaringan and tagged , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s