Konfigurasi single-area OSPF di Cisco Router

Konfigurasi OSPF di Router-JKT:
(config)# interface loopback 0
(config-if)# ip address 1.1.1.1 255.255.255.255  ==> sebagai router-id OSPF
(config-if)# no shutdown

(config-if)# router ospf 1      ==> menggunakan process-id 1
(config-router)# network 1.1.1.1    0.0.0.0 area 0
(config-router)# network 10.1.2.1   0.0.0.0 area 0
(config-router)# network 172.16.1.1 0.0.0.0 area 0
(config-router)# network 10.1.3.1   0.0.0.0 area 0
(config-router)# passive-interface f0/0    ==> interface yg tidak mengirim paket OSPF (hello, update, dll)
(config-router)# end

Konfigurasi OSPF di Router-SBY:
(config)# interface loopback 0
(config-if)# ip address 1.1.1.2 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 1
(config-router)# network 1.1.1.2    0.0.0.0 area 0
(config-router)# network 10.1.2.0   0.0.0.255 area 0
(config-router)# network 10.1.1.0   0.0.0.255 area 0
(config-router)# passive-interface f0/0
(config-router)# end

Konfigurasi OSPF di Router-MDN:
(config)# interface loopback 0
(config-if)# ip address 1.1.1.3 255.255.255.255
(config-if)# no shutdown

(config-if)# router ospf 2
(config-router)# network 1.1.1.3    0.0.0.0 area 0
(config-router)# network 172.16.1.2   0.0.0.255 area 0
(config-router)# network 192.168.1.1   0.0.0.255 area 0
(config-router)# passive-interface f0/0
(config-router)# end

Untuk verifikasi konfigurasi OSPF:
# sh ip route          ==> melihat routing table
# sh ip protocol       ==> melihat routing protocol yg telah dikonfigurasi
# sh ip ospf neighbor  ==> melihat neighbor table OSPF
# sh ip ospf database  ==> melihat LSDB OSPF
# sh ip route ospf     ==> melihat routing table OSPF

# debug ip ospf packet ==> melihat proses mengirim & menerima paket OSPF
# debug ip ospf event  ==> melihat event yg terjadi di OSPF
# terminal monitor     ==> utk melihat hasil debug (khusus bagi yg via telnet/SSH)
# no debug all  ATAU  #undebug all   ==> mematikan proses debugging

Catatan :

Di router-JKT saya tunjukkan alternatif pertama utk mengkonfigurasi OSPF network, yaitu dengan wildcard mask 0.0.0.0 (dengan catatan, harus masukkan IP address interface-nya). Nah di router-SBY saya menunjukkan alternatif ke-2 yaitu menggunakan IP network address & wildcard mask disesuaikan dengan subnet mask-nya. Cara mudah menghitung wildcard mask adalah 255.255.255.255 – subnet mask.

contoh: subnet mask /24 maka wildcard mask nya = 255.255.255.255 – 255.255.255.0 = 0.0.0.255

semoga membantu :)

sumber : http://aditya.hananto.net/2010/01/01/konfigurasi-ospf-single-area-di-cisco-router/

This entry was posted in Jaringan and tagged , , , , , . Bookmark the permalink.

2 Responses to Konfigurasi single-area OSPF di Cisco Router

  1. makasih..:)
    sangat sangat membantu ;D

  2. koko says:

    mau tany dong, tu knp di router medan proces id 2 sedangkan jkt sby proces id 1,,???

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s